2009年4月26日 星期日

[新聞翻譯]openSUSE KDE4 使用者該注意的重大新聞

原文:
http://mschlander.wordpress.com/2009/04/25/important-news-for-opensuse-kde4-users/

如果您使用 openSUSE Build Service 上的 KDE4,您應該仔細閱讀此一信息,許多重大的變更從現在起即將就要發生了。

套件庫變更
新的一系列 KDE4.2 的套件庫已經建立了,因為 factory 套件庫將在二到三周內推進到 KDE4.3 beta 1。如果您現在正使用 factory 的 KDE4.2 且想要留在 KDE4.2,您應該儘速移往這些新的套件庫。
新的 Playground 系列套件庫已建立,專門放一些 KDE4 應用程式的 alpha, beta, 以及 CVS 快照。
以前的 Extra-apps 套件庫已結束了,那些套件現在可以在 KDE4:/Community/ 或 KDE4:/Playground 套件庫找到,在哪個套件庫中取決於該套件的釋出狀態。
不同版本的 KDE 及其對應的套件庫位址的完整概觀,請參考此維基頁面 http://en.opensuse.org/KDE/Repositories

套件命名變更
以往 KDE4 套件名稱因為同時存在著 KDE3 的套件,所以會像這樣命名:kde4-[套件名稱]。現在這個法則將要顛倒過來了。KDE4 套件將不再有前置的命名,而是 KDE3 將有前置名稱,像是 kde3-[套件名稱]。
如果您在更新之後想要繼續使用某些 KDE3 套件--例如 Konversation 或 K3b--加入您的 openSUSE 版本的 KDE3 套件庫並安裝 kde3-k3b 或 kde3-konversation: http://download.opensuse.org/repositories/KDE:/KDE3/

搭載 KDE4.2 的可安裝 openSUSE 11.1 Reloaded Live CD
Stephan “Beineri” Binner 已建立了搭載 KDE4.2 的 openSUSE 11.1 live CD 的衍生版本,取名為 openSUSE 11.1 Reloaded。如果您將要全新安裝 openSUSE 11.1 且想要使用 KDE4.2,您應該考慮採用這個版本來省掉您許多的麻煩。
從這裡取得這些 ISO:
http://download.opensuse.org/repositories/KDE:/Medias/images/iso/
如果您遇到了問題,可以在 opensuse-kde@opensuse.org 的郵件列表上回報,或試著在 Freenode 的 #opensuse-kde IRC 頻道上找 Beineri 。

6 則留言:

Ajian 提到...

帮忙, 我现在用的openSUSE 11.2 KDE4.2.2 昨天在用dia画图的时候,突然键盘不能输入了,但鼠标还能使用,在登陆界面之前还可以键盘输入密码 在其它的界面或者是终端下都可以使用键盘 只有在KDE加载的最后一步的时候键盘就无法使用, 在这之前我根据这篇文章把源都改了,也升了几个小文件得我都尝试降级,今天已经基本全部降到标准的4.2.2版本,甚至怀疑是scim和KDE的冲突,我完全都scim删除,并安装了ibus(安装的只有拼音,也装了五笔但添加输入法的时候没有五笔的选项,用的是你提供的套件),现在还停用了kwin的特效等,还是无法输入,在系统管理里面无法打开keybard layout 在终端下yast可以.系统有很多的配置不希望重装,现在急需用来工作队,,帮我分析分析什么原因,谢谢.

Ajian 提到...

补充:我用鼠标操作虚拟键盘也无法使用.

swyear 提到...

ibus 我還在測試中,我不保證可以用,所以請您先將 scim 裝回來,另 11.2 只是 milestone 1的最初版本,試用可以,但很多問題必須有心裡準備,工作機請勿安裝 11.2

Ajian 提到...

确实是很奇怪 我折腾了很久之后 好了 原因没找到
但是ibus还是一样 五笔加载不了 我编译源码包也没报错 用ibus-daemon --re-scan
(ibus-daemon:6503): IBUS-DEBUG: From ::1.1 to :1.3, Error: org.freedesktop.DBus.Error.Failed : Can not get value [engine/PinYin->HalfPunctuations]

希望可以很快实验好 谢谢。

swyear 提到...

現在 ibus 有 struq (hujq)幫忙維護,或許到 linuxsir 論壇去問看,或到 ibus 網站回報問題,還是提醒您 11.2 還不能當工作機使用

Ajian 提到...

谢谢 你的提醒
我现在正在用ibus的五笔86给你回复
应该是我手动编译安装成功了 之前给你回复的时候 我还没有重启 现在重新打开后发现能用了 而且感觉挺不错的 还可以单键中英文切换 输入相当方便 比之前的scim好用多了
我现在工作机其实就是我自己工作的本本安装的 因为平时工作都是跟linux打交道 所以用同样的系统会方便很多 自己也可以定制很多脚本等智能化的一些东西 可能比较喜欢更新最新的一些东西 所以会遇到各式各样的问题 。