2011年11月21日 星期一

openSUSE 12.1 體驗報告(5)

郵件列表論壇 都會有許多人提供許多的情報,
我許多跟大家報告的東西都是由 ML 和 論壇 來的,

如果閱讀英文沒問題,您至少可以訂閱 opensuse@opensuse.org
寫一封空白郵件到 opensuse+subscribe@opensuse.org 即完成訂閱
要發問則寫信到 opensuse@opensuse.org
主要以英文討論為主

openSUSE 中文郵件列表: opensuse-zh@opensuse.org
寫一封空白郵件到 opensuse-zh+subscribe@opensuse.org 即完成訂閱
要發問則寫信到 opensuse-zh@opensuse.org
繁簡體中文皆可,目前此郵件列表蠻冷清的,
您可用中文發問,
您也可以寫個自我介紹發上來,我想大家也會歡迎的

論壇主要以英文溝通為主
若要使用中文討論
請到中文子論壇(繁簡中文通用): http://forums.opensuse.org/ae-ae-chinese/

nvidia 顯示卡驅動程式套件庫已經上線
請由 YaST--軟體套件庫--新增--社群套件庫--nVidia Graphics Drivers 來新增
請選擇並安裝適合您的『顯示卡』及『 核心類型』的套件
請參考: openSUSE NVIDIA drivers
我個人的經驗是安裝完後重開機即可直接使用,不需額外設定

停用 Apper
如果常跳出一個視窗說要設定 network proxy 要您輸入密碼
http://forums.opensuse.org/english/get-technical-help-here/applications/468131-why-authentication-required-set-network-proxy.html
您可以停用 Apper (這樣也會造成系統不會自動搜尋更新,您就要勤快手動更新了)
由 KDE 選單--系統設定--啟動與關閉--服務管理程式--取消使用 Apper Monitor

安裝 gcin
現在 gcin 可以從 M17N 套件庫安裝
http://download.opensuse.org/repositories/M17N/
openSUSE 的多國語言相關套件都是由此開發
使用以下指令:
# zypper ar obs://M17N/openSUSE_12.1 m17n
# zypper ref m17n
# zypper in gcin
正在載入套件庫資料...
讀取已安裝的套件...
正在解決套件相依性...

將會安裝下列新的套件:
gcin gcin-branding-openSUSE gcin-gtk3-immodule gcin-qt4-immodule libreoffice-gnome

5 新套件將被安裝.
全部下載大小: 2.5 MiB。 完成操作後,將增加 10.2 MiB 的使用。
要繼續嗎? [y/n/?] (y): y

我使用了 http://hyperrate.com/dir.php?eid=218 中的 kai-mono 圖示作為預設的圖示
如果您想要用上游 gcin 使用的圖示,請安裝 gcin-branding-upstream

KDE 的使用者若沒有在 gtk3-base 應用程式輸入的需求,
gcin-gtk3-immodule 不見得要安裝,
同理,GNOME3 的使用者也不一定需要 gcin-qt4-immodule,
但是終端使用者可能不見得知道,因為基本桌面安裝時,系統中都有足夠的函式庫
加上 openSUSE 12.1 預設就使用 KDE4 或 GNOME3
所以就一併請大家都安裝了

值得一提的是, openSUSE 又重新提供了 KDE3 的應用程式
如果您的應用程式套件是 kde3 開頭的,您會需要 gcin-qt3-immodule,這就要請您自行安裝了

64 位元架構的系統,若要在 32 位元應用程式中輸入,則需自行加裝 -32bit 的部份

另外 gcin 無法在 libreoffice-kde 中正確游標跟隨(輸入視窗固定在左上角,這樣會害我被老婆罵)
所以我也強制加了 libreoffice-gnome 的相依性
並在 gcin 的啟動程序中強制 libreoffice 使用 gnome 介面
如果您不是使用 gcin 時,libreoffice 則不會被影響,仍依照您系統預設來啟動相對應介面

home:swyear 套件庫仍繼續提供 gcin 套件
基本上我目前的做法是先在 home:swyear 打包,
自己試用一陣子沒問題,才會送到 M17N


gcin 現在也會自動出現在 GNOME 3 的系統匣,不需另外設定

2 則留言:

玛格丽特苏 提到...

眼珠大,不用非得停掉Apper的。。。那个跳输入root密码的东西,可以在/etc/polkit-default-privs.standard里把network-proxy这个项目依照它上面那一条的格式给写成yes。就再也不会烦你拉。停用了Apper如果不安装yast-update开头的东西的话,你就没法自动更新啦

swyear 提到...

瑪格麗特蘇:
謝謝您提供的資訊,因為我都不使用自動更新...,尤其剛裝好時有一堆軟體要裝,覺得他很煩。^^