2012年9月9日 星期日

openSUSE 12.2 的 pcmanx-gtk2

剛才有人寫信給我,關於 openSUSE 12.2 的 pcmanx-gtk2 會出現記憶體區段錯誤的問題
但是因為在手機上面看,正想回覆時,手指太粗不小心不知道按到哪裡...
信就不見了,真是抱歉,所以在此回覆

這問題我已經在 pcmanx 網站回報
http://code.google.com/p/pcmanx-gtk2/issues/detail?id=60&can=1
上游也已經在 git 中修正
所以自行編譯的 git 版本應該就不會有問題了

如果要簡單一點的解法
可以直接下載 openSUSE 12.1 版的 pcmanx-gtk2
從 home:swyear 或 network 套件庫就可以找到
用 rpm -Uvh pcmanx-gtk2*.rpm 來安裝就可以用了

Update(11 Sep.)
出事的原因是因為編譯時沒有 libtool 的環境
導致在 link libltdl.so... 之類的出了問題
現在已經修正,已提出更新的要求
https://bugzilla.novell.com/show_bug.cgi?id=779500
在 network 套件庫中已經完成修正
用以下指令安裝
# zypper ar obs://network/openSUSE_12.2 network
# zypper in --from network pcmanx-gtk2

Update(20 Sep.)
感謝 Ramax 的大力幫助
pcmanx-gtk2 的修正版本已經可以在 openSUSE-12.2-Update 中安裝更新

2 則留言:

Ramax 提到...

昨天 (9/19) 已經可以從官方 repo 安裝更新了…

Ray Chen 提到...

Ramax 謝謝你的幫忙,
以後有任何問題也希望能不吝惜賜教