2008年6月24日 星期二

openoffice.org 2.4.1

用 2.4.1 版有個好處就是『和小四說掰掰』
openSUSE 11.0 中仍搭配 2.4.0
OOo 官方中文版可以下載到 2.4.1 rc2
或者用前一篇:使用官方版的 openoffice.org 2.4 的方法對 2.4.1 再做一次
可是在 openSUSE 11.0 正式版之後,卻每開必當
/opt/openoffice.org2.4/program> ./soffice -writer
./soffice: line 254: 8436 程式記憶體區段錯誤 "$sd_prog/$sd_binary" "$@"

用這個錯誤訊息 google 一下,可以找到
http://forums.gentoo.org/viewtopic-p-5128367.html?sid=d49a29e563a51dcec9fb0d920268968e
http://bugs.gentoo.org/show_bug.cgi?id=225853
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=485833
https://bugzilla.novell.com/show_bug.cgi?id=398244
還好最後已有解答
用 OBS 的 OpenOffice.org (可直接在社群套件庫中找到)
http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.0
裏面的 2.4.1 版本可正常使用
但是上次讓我脫離 Novell 版 Office 的原因仍在
所以我還是要用 OOo 官方版本
(如果知道是哪個函式庫處理字型的,說不定將相關函式庫複製到 Novell 版也可以)
從上面 OBS 中找到 OpenOffice_org-kde 套件下載
強迫安裝
# rpm -ivh OpenOffice_org-kde --nodeps

將有問題的函式庫替換掉
# cp /usr/lib/ooo-2.0/program/libvclplug_kde680li.so /opt/openoffice.org2.4/program/libvclplug_kde680li.so.1.1

就可以用了,可惜介面就有些格格不入了

3 則留言:

- 提到...

swyear兄可以试一下IBM的Symphony 1.0是基于OpenOffice的用Eclipse写的。

另外我发现原来在10.3的时候可以从Console里直接启动,Kwrite或Kate,在11里却启动不了。我想用root权限编辑fcitx的那个配置文件,这时用vi就不方便

swyear 提到...

請用 kdesu kwrite

swyear 提到...

目前使用
OOH680_m17_native_packed-1_en-US.9310
似乎已經沒有問題了